Menu icons not visible in Spotfire Web Player client

Menu icons not visible in Spotfire Web Player client

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Article ID: KB0083531

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Updated On:

Products Versions
Spotfire Web Player 7.0 and lower

Description

Description:
When opening a report in a Web Player client (Spotfire Consumer or Spotfire Business Author), the report renders correctly but several menu icons seem to be missing from the interface.

Symptoms:
Menu icons do not show up in the Web Player client and the following error message is displayed in the detailed messages in the bottom right of the Web Player client interface:
ERROR 2015-02-25 14:17:03,496 [g4gohksnd5x5bfu12ls5vrow, 9152, WorkThread 31, spotfire WAT 1] Spotfire.Dxp.Framework.ApplicationModel.NotificationService - Operation failed
error Not Found

XmlHttpRequest failed.
Status: 404 Not Found

Cause:
The media type for SVG has not been registered on the IIS instance running the TIBCO Spotfire Web Player Server.

Issue/Introduction

Menu icons not visible in Spotfire Web Player client

Resolution

To resolve this issue, follow the steps below:
  1. On the Web Player server machine, open IIS Manager and navigate to the Web player application.
  2. In Features View, double-click MIME Types.
  3. In the Actions pane, click Add.
  4. In the Add MIME Type dialogue box, type the file name SVG.
  5. Type a MIME type in the MIME type text box. It should be: image/svg+xml
  6. Click OK.
  7. Restart IIS.

Additional Information

https://technet.microsoft.com/en-us/library/cc725608%28v=ws.10%29.aspx