Utility domainutilitycmd displays, "Domain (DomainName) does not exist" when updating domain LDAP configuration".

Utility domainutilitycmd displays, "Domain (DomainName) does not exist" when updating domain LDAP configuration".

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Article ID: KB0073263

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Updated On:

Products Versions
TIBCO Runtime Agent (TRA) -
Not Applicable -

Description

Description:
This happens when the domain uses a non-default TIBCO_TRA_DOMAIN_HOME location.
Symptoms:
[fpei@vm-rhel59-fpei bin]$ ./domainutilitycmd -cmdFile ./ModifyLDAPConfiguration.xml
Starting command line execution....
Executing task: modifyLDAPConf
Validation Failed: Domain (DomainName) does not exist.
Operation Failed.  Please view the log for more details.

Cause:
This is a known issue. TRA-2044 is reported for this.

Issue/Introduction

Utility domainutilitycmd displays, "Domain (DomainName) does not exist" when updating domain LDAP configuration".

Resolution

Workaround:

 - Use Domain Utility (GUI) mode.

 - Create the folder $TIBCO_HOME/tra/domain/domainname. Copy the domain properties AdministrationDomain.properties and AuthorizationDomain.properties to the $TIBCO_HOME/tra/domain/domainname folder, then run the domainutilitycmd again.

Other possible reasons:

  • The domain administrator credential is out of sync. Please run Domain Utility (or domainutilitycmd) and run task "Sever Settings" ->  "Update Domain Credentials". Just use the same user and password as the current ones and finish the task. This will synchronize the credentials if it is a password issue. 
  • Transport issue. Please make sure the connection to the EMS server is fine if it is an EMS domain. If it is a RV domain, please check message communication with tibrvlisten/tibrvsend, rvperfs/rvperfm. 

Please contact TIBCO Support if further assistance is needed.