Error: "Could not create connection with JMS server." after migration to TIBCO BusinessWorks version using TIBCO Runtime Agent 5.9.0 and onwards.

Error: "Could not create connection with JMS server." after migration to TIBCO BusinessWorks version using TIBCO Runtime Agent 5.9.0 and onwards.

book

Article ID: KB0093671

calendar_today

Updated On:

Products Versions
TIBCO ActiveMatrix BusinessWorks -
Not Applicable -

Description

Description:
Note: Check if the EMS client library path is present in the TRA file.

Symptoms:
The error similar to:
>>>>>>>>>>>>>>>>>>>>>>>
2014 Oct 10 09:57:45:774 GMT -0400 BW.inv_sys_instrument_adapters-InstrumentAdapterProcesses Error [BW-Core] BWENGINE-100001 process initialization failed for Process Definitions/Instrument Adapter/SmfUpdateRefresh.process
process initialization failed for Process Definitions/Instrument Adapter/SmfUpdateRefresh.process
        at com.tibco.pe.core.WorkflowBuilder.build(Unknown Source)
        at com.tibco.pe.core.WorkflowLoader.setWorkflows(Unknown Source)
        at com.tibco.pe.core.WorkflowLoader.loadWorkflows(Unknown Source)
        at com.tibco.pe.core.JobPoolConfigurator.a(Unknown Source)
        at com.tibco.pe.core.JobPoolConfigurator.if(Unknown Source)
        at com.tibco.pe.core.JobPool.<init>(Unknown Source)
        at com.tibco.pe.core.JobPoolCreator.init(Unknown Source)
        at com.tibco.pe.core.JobPoolCreator.<init>(Unknown Source)
        at com.tibco.pe.PEMain.a(Unknown Source)
        at com.tibco.pe.PEMain.do(Unknown Source)
        at com.tibco.pe.PEMain.a(Unknown Source)
        at com.tibco.pe.PEMain.<init>(Unknown Source)
        at com.tibco.pe.PEMain.main(Unknown Source)
caused by: Initialization error in [Process Definitions/Instrument Adapter/SmfUpdateRefresh.process/Adapter Subscriber]
        at com.tibco.pe.core.WorkflowBuilder.build(Unknown Source)
        at com.tibco.pe.core.WorkflowLoader.setWorkflows(Unknown Source)
        at com.tibco.pe.core.WorkflowLoader.loadWorkflows(Unknown Source)
        at com.tibco.pe.core.JobPoolConfigurator.a(Unknown Source)
        at com.tibco.pe.core.JobPoolConfigurator.if(Unknown Source)
        at com.tibco.pe.core.JobPool.<init>(Unknown Source)
        at com.tibco.pe.core.JobPoolCreator.init(Unknown Source)
        at com.tibco.pe.core.JobPoolCreator.<init>(Unknown Source)
        at com.tibco.pe.PEMain.a(Unknown Source)
        at com.tibco.pe.PEMain.do(Unknown Source)
        at com.tibco.pe.PEMain.a(Unknown Source)
        at com.tibco.pe.PEMain.<init>(Unknown Source)
        at com.tibco.pe.PEMain.main(Unknown Source)
caused by: Could not create connection with JMS server.[   Queue Connection Factory = QueueConnectionFactory
   User Name = abc
   JNDI User Name = abc
   JNDI Context URL = tcp://localhost:7222
   JNDI Context Factory = com.tibco.tibjms.naming.TibjmsInitialContextFactory
]
>>>>>>>>>>>>>>>>>>>>>>>

Cause:
EMS client libraries are no longer bundled in TIBCO Runtime Agent post 5.9.0.

Resolution

Add the EMS client libraries by running the traUpgradeManager utility with the –ems option.


traUpgradeManager -path C:\TIBCO_HOME -ems
C:\TIBCO_HOME\ems\<version>


Example:

traUpgradeManager -path C:\tibco -ems C:\tibco\ems\8.0

Issue/Introduction

Error: "Could not create connection with JMS server." after migration to TIBCO BusinessWorks version using TIBCO Runtime Agent 5.9.0 and onwards.

Additional Information

https://docs.tibco.com/pub/runtime_agent/5.9.0/TIB_TRA_5.9.0_relnotes.pdf