Error: "com.faizsiegeln.njams.dataprovider.DataProviderStatistics: unable to get configuration for dataprovider from DB java.lang.Exception: Db not inited or reachable", logged by TIBCO BusinessWorks ProcessMonitor Server.

Error: "com.faizsiegeln.njams.dataprovider.DataProviderStatistics: unable to get configuration for dataprovider from DB java.lang.Exception: Db not inited or reachable", logged by TIBCO BusinessWorks ProcessMonitor Server.

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Article ID: KB0093434

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Updated On:

Products Versions
TIBCO BusinessWorks ProcessMonitor -
Not Applicable -

Description

Description:
TIBCO BusinessWorks ProcessMonitor (BWPM) logs the following error in the server.logs if BWPM fails to communicate with the database. "com.faizsiegeln.njams.dataprovider.DataProviderStatistics: unable to get configuration for dataprovider from DB java.lang.Exception: Db not inited or reachable."

Symptoms:
Error, "com.faizsiegeln.njams.dataprovider.DataProviderStatistics: unable to get configuration for dataprovider from DB java.lang.Exception: Db not inited or reachable" will be logged in the server.logs and BWPM may become inaccessible. Data providers may go down and stop processing messages from the event queue.

Cause:
This error occurs if the database is unavailable or not accessible. There could be several reasons for database unavailability:
- Database is down.
- Due to network issues database becomes inaccessible.

Issue/Introduction

Error: "com.faizsiegeln.njams.dataprovider.DataProviderStatistics: unable to get configuration for dataprovider from DB java.lang.Exception: Db not inited or reachable", logged by TIBCO BusinessWorks ProcessMonitor Server.

Resolution

This error occurs if your database is unavailable or not accessible. Check that the database is up and accessible and ensure the TIBCO BusinessWorks ProcessMonitor (BWPM) database setting are configured correctly. If this issue persists, enable trace logs and submit for review. To enable trace level in BWPM WEBUI (Administration->System Management->Log Files->Log Level) set the log level as 'TRACE' and click update button. Stop Tomcat and clean all logs from (<TOMCAT-HOME>/webapps/bwpm/WEB-INF/logs). Restart Tomcat and provide fresh logs after loging into BWPM WEBUI once the issue occurs.

Additional Information