How to configure Spotfire Web Player Keep Alive Service for Windows authentication

How to configure Spotfire Web Player Keep Alive Service for Windows authentication

book

Article ID: KB0082972

calendar_today

Updated On:

Products Versions
Spotfire Web Player 7.0 and lower

Description

Description:
The keep alive service continuously calls the Web Player website in order to prevent it from going down due to inactivity when scheduled updates is in use.

Symptoms:
Spotfire Spotfire.Dxp.Web.KeepAlive.log shows:
ERROR 2015-03-27 07:23:43,817 [29, (null)] Spotfire.Dxp.Web.KeepAlive.PingService - Failed to connect to the Web Player Application.
System.Net.WebException: The remote server returned an error: (401) Unauthorized.
   at System.Net.HttpWebRequest.GetResponse()
   at Spotfire.Dxp.Web.KeepAlive.PingService.PingWebPlayer()

Cause:
The calls may fail if the the keep alive service cannot authenticate correctly. When using Windows authentication, the Windows service must be run under a user account which has access to and can log in to the Web Player.

Issue/Introduction

How to configure Spotfire Web Player Keep Alive Service for Windows authentication.

Resolution

Spotfire.Dxp.Web.KeepAlive.exe.config should have a blank WindowsUsername and WindowsPassword.
 
           [...]
            <setting name="WindowsUserName" serializeas="String">
                <value></value>
            </setting>
            <setting name="WindowsPassword" serializeas="String">
                <value></value>
            </setting>
            [...]

The service must be run as a user that can log in to the Web Player.
  1. Configure this from Windows "Services". Start -> Search for "Services" application and start it.
  2. Locate the Web Player keepalive service, right click and choose "Properties" .
  3. On the "Log On" tab, select the desired account and enter the password for the user. Press OK.
  4. Restart the service.