Process Definitions not displayed in TIBCO BusinessWorks ProcessMonitor server GUI.

Process Definitions not displayed in TIBCO BusinessWorks ProcessMonitor server GUI.

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Article ID: KB0092524

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Updated On:

Products Versions
TIBCO BusinessWorks ProcessMonitor -
Not Applicable -

Description

Description:
When clicking on a job in the TIBCO BusinessWorks ProcessMonitor Server GUI, unable to see the process diagram.

Symptoms:
In the TIBCO BusinessWorks ProcessMonitor Server GUI, when clicking on the job, the process diagram tab (right of the main view) shows the following message:
"process definition not found, please click here to download". The screenshot for the same is attached. (Filename: bwpm.png).


Cause:
This occurs when using incompatible TIBCO BusinessWorks ProcessMonitor (BWPM) client JAR versions.

Example: The BWPM server version is 3.x and is using BWPM 2.x client JAR file.

Issue/Introduction

Process Definitions not displayed in TIBCO BusinessWorks ProcessMonitor server GUI.

Resolution

1). To resolve this issue, the TIBCO BusinessWorks ProcessMonitor (BWPM) client version needs to be updated so that it is compatible with the BWPM Server version. In the example above, upgrade the BWPM client version to  3.x. and restart applications.

2). In case the issue is not resolved, click on the "please click here to download" link to view the processes.

Attachments

Process Definitions not displayed in TIBCO BusinessWorks ProcessMonitor server GUI. get_app