"WARNING: File system full" message when running the EMSA CLI command.

"WARNING: File system full" message when running the EMSA CLI command.

book

Article ID: KB0093069

calendar_today

Updated On:

Products Versions
TIBCO Enterprise Message Service Appliance -
Not Applicable -

Description

Description:
"WARNING: File system "/" full" and "WARNING: File system '/' has less than 5G available!" message when running the EMSA CLI command.
Symptoms:
When running the EMSA CLI command, the following warning messages are seen:
WARNING: File system '/' is 100% full!
WARNING: File system '/' has less than 5G available!
Cause:

Due to following two defects, the root file system could be filed up.


EMSA-863: Mon_agent logged an exception to the services logfile repeatedly filling the root filesystem

EMSA-864: Mon-agent encountering a "filedescriptor out of range in select" exception filled root with a larger service error log


These two defects are fixed in EMSA 2.2.1.

Issue/Introduction

"WARNING: File system full" message when running the EMSA CLI command.

Resolution

Find the huge files being generated by these two defects. They are:


/hddpool/hddfs/ems/logs/mon_agent.log

/var/svc/log/system-tibco-mon-agent:default.log

Clean up these two files.

cp /dev/null /hddpool/hddfs/ems/logs/mon_agent.log

cp /dev/null /var/svc/log/system-tibco-mon-agent:default.log


Or use : "cat /dev/null > <large file>" to clean up the big files.


Reboot the appliance. If it is an EMSA FT pair, after rebooting one appliance, you will need to run the "restore-primary-active" EMSA CLI command to restore the original primary active servers to become active.