Individual PTF backups for TIBCO Object Service Broker Database Upgrades can disappear.

Individual PTF backups for TIBCO Object Service Broker Database Upgrades can disappear.

book

Article ID: KB0092600

calendar_today

Updated On:

Products Versions
TIBCO Object Service Broker for z/OS -
Not Applicable -

Description

Description:
If a database PTF (Program Temporary Fix) is applied more than once, the data in the backup file from the first instance will be removed. This applies to only TIBCO Object Service Broker for z/OS.
Symptoms:
After a database upgrade, the backups generated for individual PTFs can be found empty.
Cause:
This can happen if an upgrade (at a release boundary or for a hotfix) is interrupted and restarted. It can also occur if multiple hotfixes are applied at once.

When a PTF is being applied as part of a database upgrade, a backup file for the PTF is created as an empty file before the PTF itself is applied. If the PTF has not already been applied, the dataset is populated with the appropriately backed-up data. If the PTF is found already to be in the database, nothing is done and the backup dataset remains empty. As a result, any repeated attempt to apply the same PTF will cause the backed-up data to disappear.

ON z/OS, the backups are created in


 $HLQNONV$.BKxxxx.UPGRADE

where xxxx is a number unique to each change.

Issue/Introduction

Individual PTF backups for TIBCO Object Service Broker Database Upgrades can disappear.

Resolution

The first step in upgrading the database is to create a full backup of Segment 0. This is the primary backup, and should be used to restore the previous state of the database if this becomes necessary.

The backups created for individual PTFs during a database upgrade are of limited utility. Because there can be dependencies among PTFs, it is not guaranteed that backing out a single change by restoring its backup will be safe. If you need to back out a change, it is always safest to back out the entire upgrade by following the instructions in the README that accompanies the hotfix. To ensure that the backups for individual database PTFs are preserved, do the following.

Interrupted Database Upgrades:

To improve performance, some tables in Segment 0 are bound by default. Occasionally, a user may choose to bind other Segment 0 tables. The process that performs database upgrades starts by unbinding the tables that it expects to have been bound. If you have bound some other table in Segment 0, and changes to that table are included in the upgrade, then the upgrade will fail when it tries to update it. In this case, you should restore the database backup made before the upgrade, then un-bind the table and start the database upgrade again. This will ensure that a complete set of PTF backups is created.

Repeated Application of a PTF:

Each hotfix contains all of the changes of its predecessors. If you wish to preserve the backups that are created for individual database PTFs, copy them to a safe place before applying a later database hotfix.