Duplicate Document ID generated by BusinessConnect.

Duplicate Document ID generated by BusinessConnect.

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Article ID: KB0093112

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Description:
A BusinessWorks process generating Document IDs for BusinessConnect outbound documents may generate a duplicate ID for different transactions.
Symptoms:
As described.
Cause:
There is an issue with how the BC Palette generates the Document ID inside BusinessWorks.

Issue/Introduction

Duplicate Document ID generated by BusinessConnect.

Resolution

As a workaround, disable the "Generate Uniqute Transaction ID" in the BC Palette and generate the Document ID manually by using the following formula:


“prefix+EngineName+ProcessID+timestamp”


The prefix is customer defined to differentiate deployments. The EngineName,ProcessID, and timestamp are BW5 engine process variables.