Edimigrator error when importing a BC configuration from a BC 5.3.3 previous installation.

Edimigrator error when importing a BC configuration from a BC 5.3.3 previous installation.

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Article ID: KB0092458

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Updated On:

Products Versions
TIBCO BusinessConnect EDI Protocol Powered by Instream -
Not Applicable -

Description

Description:
When trying to migrate an EDI installation into a BC 6.X environment using the Edimigrator tool, Edimigrator fails.
Symptoms:
The following exceptions is thrown in the logs:

[2015-04-30 10:52:13,794 (INFO )]   options validation is done
[2015-04-30 10:52:13,810 (INFO )]   Import started.
[2015-04-30 10:52:14,746 (ERROR)]   Error during accessing CSX file content. The input data may be corrupt or damaged.
        at com.tibco.ax.fw.util.cfgix.ConfigIX.int(ConfigIX.java:2430)
        at com.tibco.ax.fw.util.cfgix.ConfigIX.a(ConfigIX.java:878)
        at com.tibco.ax.fw.util.cfgix.ConfigIX.a(ConfigIX.java:865)
        at com.tibco.ax.fw.util.cfgix.ConfigIX.discoverContent(ConfigIX.java:1068)
        at com.tibco.ax.tibedi.util.EDIMigrator$MigrationHelper.doCsxImport(EDIMigrator.java:296)
        at com.tibco.ax.tibedi.util.EDIMigrator$MigrationHelper.migrate(EDIMigrator.java:246)
        at com.tibco.ax.tibedi.util.EDIMigrator.execute(EDIMigrator.java:183)
        at com.tibco.ax.tibedi.util.EDIMigrator.main(EDIMigrator.java:162)

Cause:
Not enough disk space in the /tmp directory.

Issue/Introduction

Edimigrator error when importing a BC configuration from a BC 5.3.3 previous installation.

Resolution

Increase the amount of disk space available in the /tmp area.  There should be a minimum of 5 GB availabile.