Issue with TIBCO Nimbus Performance Monitor on 64 bit versions of Windows

Issue with TIBCO Nimbus Performance Monitor on 64 bit versions of Windows

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Article ID: KB0092751

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Updated On: 01-14-2017

Products Versions
TIBCO Nimbus -
Not Applicable -

Description

Description:
When running the TIBCO Nimbus Performance counters on 64 bit versions of the Windows operating system the counters do not record any results in log files even when running the 32 bit version of Windows Performance Monitor (PerfMon) via “mmc.exe /32 perfmon.msc”. The counters do show in Performance Monitor, just not in log files. If a log file that is created when it is opened it will be blank and the following error message is usually displayed: “The data source is not in active mode, this is generally caused by invalid log files.” 
Symptoms:
When running the TIBCO Nimbus Performance counters on 64 bit versions of the Windows operating system the counters do not record any results in log files even when running the 32 bit version of Windows Performance Monitor (PerfMon) via “mmc.exe /32 perfmon.msc”. The counters do show in Performance Monitor, just not in log files. If a log file that is created when it is opened it will be blank and the following error message is usually displayed: “The data source is not in active mode, this is generally caused by invalid log files.” 
Cause:
As the current TIBCO Nimbus performance counters are provided by a 32 bit DLL file they can only be loaded by a 32 bit process. This is the reason that the 32 bit version of Performance Monitor needs to be run. However when using Data Collector sets there is another process completing the logging and by default it’s a 64 bit process and so cannot load the TIBCO Nimbus performance counter DLL file. This leads it to log empty entries. To resolve this situation Windows 2008 R2 and later provides additional support to host 32 bit counter dlls. However due to a bug in the registration code in the TIBCO Nimbus performance counter library (cesctrs.dll) an incorrect registry key is created that prevents this support from working.

Issue/Introduction

Issue with TIBCO Nimbus Performance Monitor on 64 bit versions of Windows

Resolution

Rectify the incorrect registration issue:

1. Run “Regedit.exe”. This will require administrator level access  Ensure you have made a backup of the Registry!
2. Navigate to the following key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TIBCO Nimbus\Performance
3. The “Library” entry is pointing to the “system32” folder where 64 bit executable files are placed (for historic compatibility). However the TIBCO Nimbus performance counter (cectrs.dll) is installed to the correct folder for a 32 bit DLL namely “C:\Windows\SysWOW64” Therefore the entry needs to be updated by replacing the “system32” part with “SysWoW64” to become “C:\Windows\SysWOW64\cesctrs.dll”. Note the path parts are not case sensitive

Enable the support in Windows 2008 R2 and later for 32 bit counters:

1. Open the services manager by running “services.msc” 
2. Scroll down to two entries for “Performance Counter DLL host” and “Performance Logs & Alerts” 
3. By default these two services are manual start, but need to be changed to “Automatic” start 

Once both of the steps above have been completed and the services started then Performance Monitor data collector sets should work as expected once restarted.