Failed to find the start class error seen with TIBCO BusinessWorks ProcessMonitor Client.

Failed to find the start class error seen with TIBCO BusinessWorks ProcessMonitor Client.

book

Article ID: KB0093537

calendar_today

Updated On:

Products Versions
TIBCO BusinessWorks ProcessMonitor -
Not Applicable -

Description

Description:
When attempting to start a TIBCO ActiveMatrix BusinessWorks application in non-invasive monitoring mode (implicit mode) of TIBCO BusinessWorks ProcessMonitor (BWPM) Client, it fails with the error, "com/tibco/processmonitor/client/run " - bad classpath?
Symptoms:
The following error is seen in the application.log.

Failed to find the start class, "com/tibco/processmonitor/client/run " - bad classpath?

Exception in thread "main" java.lang.NoClassDefFoundError: com/tibco/processmonitor/client/run

Caused by: java.lang.ClassNotFoundException: com.tibco.processmonitor.client.run

        at java.net.URLClassLoader$1.run(Unknown Source)

        at java.net.URLClassLoader$1.run(Unknown Source)

        at java.security.AccessController.doPrivileged(Native Method)

        at java.net.URLClassLoader.findClass(Unknown Source)

        at java.lang.ClassLoader.loadClass(Unknown Source)

        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)

        at java.lang.ClassLoader.loadClass(Unknown Source)



Cause:
A whitespace after the file extension in the startclass, which is in application.tra/bwengine.tra, that is,
"java.start.class=com.tibco.processmonitor.client.run " is present in the application.tra/bwengine.tra.

Issue/Introduction

Failed to find the start class error seen with TIBCO BusinessWorks ProcessMonitor Client.

Resolution

Remove the extra space after the file extension in the startclass from the application.tra/bwengine.tra.

Example:
Update

"java.start.class=com.tibco.processmonitor.client.run "

To

"java.start.class=com.tibco.processmonitor.client.run"

Restart the application for the change to take affect.