Unable to delete expired credential from BusinessConnect trading partner.

Unable to delete expired credential from BusinessConnect trading partner.

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Article ID: KB0094053

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Description:
When attempting to delete a certificate from a BusinessConnect trading partner, the deletion fails.
Symptoms:
When attempting to delete a certificate, the BusinessConnect Administrator errors out with: "Failed to remove credential. KeyStoreItem: <certificate name>, cannot be deleted as it is currently bound to one or more secured Transports, or used by Document Security settings in one or more Business Agreements". 

In inspecting the relevant BusinessAgremeents, no usage of the certificate is seen.

Cause:
Defect in how the certificate is stored in the BusinessAgreement.

Issue/Introduction

Unable to delete expired credential from BusinessConnect trading partner.

Resolution

Go into the relevant BusinessAgreement and delete all operation transactions for the Host and Trading partner ". . . can initiate" screen.  You will then be able to delete the certificate. NOTE:  A BC engine restart may be required if an alert continues to be generated from the Expiry Monitor.

Additional Information

BusinessConnect Trading Partner Administration Guide.