Socket write error is logged in TIBCO BusinessWorks ProcessMonitor server logs.

Socket write error is logged in TIBCO BusinessWorks ProcessMonitor server logs.

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Article ID: KB0094055

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Updated On:

Products Versions
TIBCO BusinessWorks ProcessMonitor -
Not Applicable -

Description

Description:

The following error is seen in TIBCO BusinessWorks ProcessMonitor (BWPM) server.logs:

com.faizsiegeln.njams.util.JSONUtilities: ClientAbortException:  java.net.SocketException: Connection reset by peer: socket write error.


Symptoms:
The following error is seen in the server logs while navigating into different views/tabs before content is loaded in the respective tabs of TIBCO BusinessWorks ProcessMonitor Server GUI:

2015-08-20 14:28:03,513 ERROR [http-8141-4] com.faizsiegeln.njams.util.JSONUtilities: ClientAbortException:  java.net.SocketException: Connection reset by peer: socket write error
Cause:
This error is usually a consequence of some action on the end user side (i.e. in the web browser where you are accessing TIBCO BusinessWorks ProcessMonitor GUI). For example, if the user clicks on a domain object in technical view and suddenly moves from admin view of the navigation to a process diagram tab, or selects other domain object in technical view, this error can occur.

Issue/Introduction

Socket write error is logged in TIBCO BusinessWorks ProcessMonitor server logs.

Resolution

This issue occurs if the TIBCO BusinessWorks ProcessMonitor (BWPM) server is trying to fetch data from a Tomcat server/database and before a request is completed, the user navigates to another view/domain object in the BWPM GUI. Due to this, the previous request gets closed/aborted and the error occurs. However, if a previous request completes before you navigate to another view/domain object in BWPM GUI, the reported issue will not be logged. This error can be ignored as this is a warning about a request cancelled or connection reset by a peer occurring while the request was in process at the BWPM server.