Unable to see folders in the TIBCO Nimbus web server, despite seeing them in the Author client.

Unable to see folders in the TIBCO Nimbus web server, despite seeing them in the Author client.

book

Article ID: KB0084021

calendar_today

Updated On:

Products Versions
TIBCO Nimbus -
Not Applicable -

Description

Description:
The AdminAll.npdta is a file designed in older versions of Nimbus to allow open access rights to administrators, bypassing the Diagram Access Rights set up within the Client.
This file can cause some strange permissions issues to crop up within the later versions of Nimbus.
This causes some folders to appear within the Author Client of the Software but not in the Web Version, but only for Administrator accounts, as that is the User type that AdminAll.npdta effects

Symptoms:
Having Folders or Maps visible within the Author Client but this not shown in the Web for Administrator accounts only.

Cause:
The AdminAll.npdta files Access overwrite causes this issue.

Issue/Introduction

Unable to see folders in the TIBCO Nimbus web server, despite seeing them in the Author client.

Resolution

Remove the AdminAll.npdta file from the Root of the Process Repository in Nimbus.
This file should not be used as a permanent measure in any case.