TIBCO BusinessWorks ProcessMonitor Database instance not visible on the login page.

TIBCO BusinessWorks ProcessMonitor Database instance not visible on the login page.

book

Article ID: KB0093043

calendar_today

Updated On:

Products Versions
TIBCO BusinessWorks ProcessMonitor -
Not Applicable -

Description

Description:
The database connection in the TIBCO BusinessWorks ProcessMonitor Sever setup is successful and a database schema is created successfully. No errors were reported during schema creation but the database instance name is not seen on the login page. The JMS configuration screen in the Administration tab is also not loaded as a result.

Symptoms:
The database instance name is not seen on the login page and the following exception is seen in the server logs:-

com.microsoft.sqlserver.jdbc.SQLServerException: Invalid object name 'NJAMS_T_CONFIGURATION'.
    at com.microsoft.sqlserver.jdbc.SQLServerException.makeFromDatabaseError(SQLServerException.java:216)
    at com.microsoft.sqlserver.jdbc.SQLServerStatement.getNextResult(SQLServerStatement.java:1515)
    at com.microsoft.sqlserver.jdbc.SQLServerPreparedStatement.doExecutePreparedStatement(SQLServerPreparedStatement.java:404)
    at com.microsoft.sqlserver.jdbc.SQLServerPreparedStatement$PrepStmtExecCmd.doExecute(SQLServerPreparedStatement.java:350)
    at com.microsoft.sqlserver.jdbc.TDSCommand.execute(IOBuffer.java:5696)
    at com.microsoft.sqlserver.jdbc.SQLServerConnection.executeCommand(SQLServerConnection.java:1715)
    at com.microsoft.sqlserver.jdbc.SQLServerStatement.executeCommand(SQLServerStatement.java:180)
    at com.microsoft.sqlserver.jdbc.SQLServerStatement.executeStatement(SQLServerStatement.java:155)
    at com.microsoft.sqlserver.jdbc.SQLServerPreparedStatement.execute(SQLServerPreparedStatement.java:332)
    at com.faizsiegeln.njams.util.JDBCUtilities.doDatabaseCall1(JDBCUtilities.java:630)
    at com.faizsiegeln.njams.util.JDBCUtilities.doDatabaseCall0(JDBCUtilities.java:599)
    at com.faizsiegeln.njams.util.JDBCUtilities.doDatabaseCall0(JDBCUtilities.java:585)
    at com.faizsiegeln.njams.util.JDBCUtilities.doDatabaseCall(JDBCUtilities.java:561)
    at com.faizsiegeln.njams.util.JdbcConfigEntryUtilities.findAllEntries(JdbcConfigEntryUtilities.java:53)
    at com.faizsiegeln.njams.util.JdbcConfigEntryUtilities.findAllEntries(JdbcConfigEntryUtilities.java:43)
    at com.faizsiegeln.njams.util.JdbcConfigEntryUtilities.findAllEntries(JdbcConfigEntryUtilities.java:38)
    at com.faizsiegeln.njams.cluster.Configuration.load(Configuration.java:79)
    at com.faizsiegeln.njams.services.ClusterManagementService.restart(ClusterManagementService.java:454)
.......

Cause:
This error occurs because:

1). The version of the sqljdbc4.jar is not according to what is required. This is mentioned in the Installing TIBCO BusinessWorks Process Monitor Server.pdf file.
2). This error is also seen when the database user is not the owner of the created TIBCO BusinessWorks ProcessMonitor Sever database.

Issue/Introduction

TIBCO BusinessWorks ProcessMonitor Database instance not visible on the login page.

Resolution

1). The following JDBC driver versions are supported with this release of TIBCO BusinessWorks ProcessMonitor Sever, both for MS SQL Server 2008 and MS SQL Server 2012. Use sqljdbc4.jar for the following vesion:

4.0.2206.100

2). The exception seen in the server logs indicates that 'NJAMS_T_CONFIGURATION' does not exist. However, this table does exist in the database. This issue is actually related to the ownership and default schema of the database.

Prepare your MS SQL Server database by creating an BWPM database (e.g. bwpmDB) and a BWPM database user (e.g. bwpmUser) and schema (e.g. bwpm). Set the bwpmUser as owner of bwpmDB. Make sure that the user’s default schema is set to the correct schema (e.g.bwpm). BWPM requires READ_COMMITTED. This is also mentioned in the "Installing TIBCO BusinessWorks Process Monitor Server.pdf" file.

Additional Information

Installing TIBCO BusinessWorks Process Monitor Server.pdf file.