Inconsistent behavior of BC palette in BusinessWorks projects.

Inconsistent behavior of BC palette in BusinessWorks projects.

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Article ID: KB0093852

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Description:
User may notice inconsistent or incorrect behavior of the BusinessConnect tasks in BusinessWorks projects.  
Symptoms:
Symptoms may include EMS subscription not active for specific protocols, BC fields missing in BC process starters or missing fields in messages to BusinessConnect from the project.
Cause:
The BusinessConnect connection, process starter or task was created by copying an existing component rather than creating a new version. The copied component does not have all the information necessary to operate successfully.

Issue/Introduction

Inconsistent behavior of BC palette in BusinessWorks projects.

Resolution

Never create a new BusinessConnect connection, process starter or task by copying an existing BC component in a Designer project. Instead, always create new instances of the components from the Palette window or by right-click on "Add Resource . . ." in the Designer.

Additional Information

TIBCO BusinessConnect Services Plug-in User’s Guide.