Outbound calls for services withWS Security enabledworks in Business Studio but fails when deploying to an appnode.

Outbound calls for services withWS Security enabledworks in Business Studio but fails when deploying to an appnode.

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Article ID: KB0093780

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Updated On:

Products Versions
TIBCO ActiveMatrix BusinessWorks -
Not Applicable -

Description

Description:
Outbound calls for services with WS Security enabled would work in Business Studio but fail on deploying to an appnode.
Symptoms:
The following error is seen in bwappnode.log.

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ERROR [bwEngThread:In-Memory Process Worker-3] com.tibco.bw.core - TIBCO-BW-CORE-500050: The BW process [reportingservice.ReportServiceProcess] instance faulted, JobId [bw0a100], ProcessInstanceId [bw0a100], ParentProcessInstanceId [-], Module [ReportingService:1.0.0.201508271926], Application [ReportingService.application:1.0].  
   <CausedBy> TIBCO-BW-CORE-500052: Invoke activity [CallGetRptInstancesContent] fault.  
   <CausedBy> com.tibco.bw.binding.soap.BWSOAPReferenceBindingException: TIBCO-BW-BINDING-SOAP-550100: Received SOAP Fault from the service provider of the Operation [{http://www.citco.com/reporting/wsdl}GetReportInstancesContent], SoapReferenceBinding [SOAPReferenceRptWS], Application [ReportingService.application:1.0].  SOAP Fault received: [<?xml version='1.0' encoding='utf-8'?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Body><soapenv:Fault><faultcode>soapenv:Client</faultcode><faultstring xml:lang="en">No WS-Security header found</faultstring></soapenv:Fault></soapenv:Body></soapenv:Envelope>]
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Cause:
The governance agent is disabled. 

Issue/Introduction

Outbound calls for services withWS Security enabledworks in Business Studio but fails when deploying to an appnode.

Resolution

The governance agent is disabled by default. In order to apply security policies, enable the bw.governance.enabled property using the following steps.

- Log in to the TEA Server and click the BusinessWorks icon to go to ActiveMatrix BusinessWorks. The Domain Management page will be displayed. Click the AppSpace icon to open the AppSpace page.

- Click the AppSpace hosting your application. On the AppSpaces page, click the Configure icon to view a list of AppSpace properties. You can also clickConfigure the icon in the upper right of the AppSpace page.

- Scroll down to find the "bw.governance.enabled property". By default, the value is "False".

- Type "True" and click the "Check" icon to enable the governance agent. Confirm you enter the value under the "Current Value" column.

- Stop and restart the AppSpace to apply the changes.