Unable to install Business Connect on VM's.

Unable to install Business Connect on VM's.

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Article ID: KB0093733

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Description:
When trying to install BusinessConnect on Linux based systems, the following exception occurs." RV dependency check".
Symptoms:
The BusinessConnect installation fails with "RV dependency check" Exception.
Cause:
The Business Connect Installer is not able to find the specified TIBCO_HOME during the installation process. This leads to an RV dependency check exception as it fails to find RV_HOME due to a wrong or corrupt TIBCO_HOME. entry

Issue/Introduction

Unable to install Business Connect on VM's.

Resolution

First, refer to KB article 45709 and make sure that all RV entries are populated properly in the vpd.properties file.  

During the installation process, the Tibco Universal Installer checks if there is an existing TIBCO_HOME directory. If there is, it will give you the option to select the current Tibco_Home. However, in some rare circumstances, customers may map different directories which results in the Universal Installer picking up a directory which is not the real TIBCO_HOME, due to some inconsistency with the mapping structure.  In that case, directly enter and execute the command "echo $TIBCO_HOME" in a a terminal and check if the output matches the entry that the Tibco Universal Installer is using. Once you determine that, you can make the required changes so that both the environment as well the Installer are using the same TIBCO_HOME entry.