Gateway Server will not start and does not appear in the Administrator.

Gateway Server will not start and does not appear in the Administrator.

book

Article ID: KB0093952

calendar_today

Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Description:
Gateway Server will not start and does not appear in the Administrator.
Symptoms:
 In the Gateway Server log file, the following exception is reported:


[2015-12-02 15:05:27,796(INFO )]GatewayServer Initializing secure token...
[2015-12-02 15:05:28,181(INFO )]Initializing Entrust crypto provider in NON FIPS 140-2 mode; insert provider as normal
[2015-12-02 15:05:31,769(INFO )]GatewayServer Initializing RV transport...
[2015-12-02 15:05:31,790(INFO )]GatewayServer Idle bootstrap ...
[2015-12-02 15:05:32,521(INFO )]GatewayServer Ack Idle bootstrap ...
[2015-12-02 15:05:32,663(ERROR)]GatewayServer com.tibco.ax.gs.runtime.GatewayRuntimeException: Idle bootstrap failed.
at com.tibco.ax.gs.runtime.GatewayServer.idleBootStrap(GatewayServer.java:267)
at com.tibco.ax.gs.runtime.GatewayServer.init(GatewayServer.java:114)
at com.tibco.ax.gs.runtime.GatewayServer.<init>(GatewayServer.java:81)
at com.tibco.ax.gs.runtime.GatewayServer.Startup(GatewayServer.java:618)
Caused by: com.tibco.ax.gs.runtime.ISException: Got exception from server: Failed to process Self Service request: Invalid request envelope
at com.tibco.ax.gs.runtime.impl.GSBootstrapUtil.checkException(GSBootstrapUtil.java:462)
at com.tibco.ax.gs.runtime.impl.GSBootstrapUtil.getDocFromDmzMsgResponse(GSBootstrapUtil.java:431)
at com.tibco.ax.gs.runtime.GatewayServer.idleBootStrap(GatewayServer.java:259)
... 3 more

Cause:
The runtime tables are not present in the BC database connection.

Issue/Introduction

Gateway Server will not start and does not appear in the Administrator.

Resolution

Check for the existence of the BC database tables in the "Runtime Data Store" schema.  If they do not exist, create them using either the "Export DDL for the database table schemas" button or the "Drop and recreate the database tables" button under the Administrator>BusinessConnect>System Settings>Audit, Non-Repudiation and Runtime Database Configuration screen.

Additional Information

BC Interior Server Administration Guide