Error thrown when a user tries to edit an application which has not been previously closed/saved.

Error thrown when a user tries to edit an application which has not been previously closed/saved.

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Article ID: KB0093702

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Updated On:

Products Versions
TIBCO API Exchange -
Not Applicable -

Description

Description:

The following error message is seen on the Portal UI when trying to edit an application.

 

"Save failed with the following error: You cannot edit this item. It is being edited at the moment or was not properly closed".


Steps to replicate the error:


1). Edit an application and close the browser without saving the changes.

2). Log in as a different user and edit the same application.

Symptoms:
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Cause:
When a user tries to edit an application, a lock is applied on that application so that no other user can edit it. You can see the lock in Joomla Administrator UI /Components/Cobalt8/Records/{Application Name}. Therefore, after completing editing, if the browser is closed abruptly or the user signed out with out saving the changes or cancelling them, the lock on the application still persists. When a different user (even a host admin) tries to edit the same application, an error message is displayed saying the application can not be edited due to the existence of the lock.

Issue/Introduction

Error thrown when a user tries to edit an application which has not been previously closed/saved.

Resolution

When you see this error message, click on the Cancel button on the edit application page. This will remove the lock on the application. Now choose to edit the application again and you will be able to edit it successfully.

Additional Information

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