TIBCO Spotfire Web Player restarting frequently after Windows Updates.

TIBCO Spotfire Web Player restarting frequently after Windows Updates.

book

Article ID: KB0079375

calendar_today

Updated On:

Products Versions
Spotfire Web Player 7.0 and lower

Description

The TIBCO Spotfire Web Player restarts multiple times a day. This is often seen after Windows Updates have been applied.

Symptoms:

Symptoms of a Web Player restart are:

  • The Web Player may be completely unavailable to users until the application has restarted.
  • User sessions are terminated causing some users to see the error "The requested analysis is not loaded on the server.  The analysis with id <analysis-id> is not found in session <session-id>.  This may indicate that the server has been restarted." See KB: 39850 Web Player error: 'The requested analysis is not loaded on the server' for more details.
  • Reports loaded in Scheduled Updates to be completely reloaded (unless file cache is enabled in Spotfire 7.0).

The only indication in the Spotfire.Dxp.Web.Log or the Spotfire.Dxp.Web.Log will be the log entry that indicates the Web Player has already shutdown and is starting up:

...
INFO  2015-12-15 10:19:15,648 [4396, WorkThread 30, user WAT 6] Spotfire.Dxp.Web.WebApplicationThread - Invoke calling invocation method during a prompting operation.
INFO  2015-12-15 10:19:39,610 [17600, 1, (null)] Spotfire.Dxp.Web.Forms.Global - Web application starting...

INFO  2015-12-15 10:19:39,813 [17600, 1, (null)] Spotfire.Dxp.Web.SiteManager - Machine environment: Name=myTSWP, OS Version=Microsoft Windows NT 6.1.7601 Service Pack 1, Is 64 bit OS=True, Processor count=24, .NET version=4.0.30319.34209.

...
 

The following event will be seen in the Windows Application Events (Event Viewer > Windows Logs > Application). This is the most important symptom of this particular issue:

Log Name:      Application
Source:        Application Error
Date:          12/15/2015 10:19:16 AM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      myTSWP.myDomain.com
Description:
Faulting application name: w3wp.exe, version: 7.5.7601.17514, time stamp: 0x4ce7afa2
Faulting module name: ntdll.dll, version: 6.1.7601.19045, time stamp: 0x56259295
Exception code: 0xc0000374
Fault offset: 0x00000000000bffc2
Faulting process id: 0x3a38
Faulting application start time: 0x01d11eae596dc662
Faulting application path: c:\windows\system32\inetsrv\w3wp.exe
Faulting module path: C:\windows\SYSTEM32\ntdll.dll
Report Id: 44d7a4f2-8ab4-11e5-b6b3-005056b20a2d

The following Windows Application event may be seen earlier:

Log Name:      Application
Source:        .NET Runtime
Date:          12/15/2015 10:16:50 AM
Event ID:      1026
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      myTSWP.myDomain.com
Description:
Application: w3wp.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.AccessViolationException
Stack:
   at System.Drawing.SafeNativeMethods+Gdip.GdipDrawString(System.Runtime.InteropServices.HandleRef, System.String, Int32, System.Runtime.InteropServices.HandleRef, System.Drawing.Internal.GPRECTF ByRef, System.Runtime.InteropServices.HandleRef, System.Runtime.InteropServices.HandleRef)
...

 

Cause:

There is a known issue with Microsoft KB3097877, also called MS15-115, which has caused application crashes in numerous applications (not only TIBCO Spotfire Web Player). Microsoft has re-issued an update to the patch, which may resolve some of the earlier issues.

Issue/Introduction

TIBCO Spotfire Web Player restarting frequently after Windows Updates.

Resolution

1). Confirm if KB3097877 (MS15-115) is installed on the Web Player server. To do this, consult with your Windows Administrator or run the following command from the command prompt (see KB: 42451 "How to capture all installed Windows updates and all installed programs with WMIC" for more details).

 

wmic qfe
or
wmic qfe > myInstalledOSPatches.txt
 
2). Remove the problematic update KB3097877 (MS15-115).  To do this:
 
 a). Open Installed Updates by clicking the Start button Picture of the Start button, clicking Control Panel, clicking Programs, and then, under Programs and Features, clicking View installed updates.
 
 b). Select the update that you want to remove, and then click Uninstall.  Administrator permission is required. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

Additional Information

KB3097877 (MS15-115):