Warning in Administrator log, "ServiceContainerBindingRuntimeConfiguration."

Warning in Administrator log, "ServiceContainerBindingRuntimeConfiguration."

book

Article ID: KB0094121

calendar_today

Updated On:

Products Versions
TIBCO ActiveMatrix BusinessWorks -
Not Applicable -

Description

Description:
Warning message in administrator.log file follows:

Warn [ServiceContainerBindingRuntimeConfiguration] AESDKJ-0000 [RVAgentManagerTransport dispatch thread]  Failed to retrieve ServiceRuntimeConfiguration while getting binding from binding runtime: 52b1084b_150f65834e2_-7ff6c0b16d74 
Symptoms:
Error: "Failed to retrieve ServiceRuntimeConfiguration while getting binding from binding runtime. "
Cause:
Hawkagent/Admin becomes unstable.

Issue/Introduction

Warning in Administrator log, "ServiceContainerBindingRuntimeConfiguration."

Resolution

The above warning indicates that the deployment configuration information is incomplete. The binding info (service instance configuration) can not be retrieved from the domain data. This usually indicates there is a deployment failure or the domain data

iinconsistent. 


This is usually dues to some resources where limited and might cause Hawkagent/Admin unstable. Do the following instructions to make a clean environment for the domain and collect more info to investigate:


1). Increase the heap size for Hawkagent in hawkagent_<Domain_Name>.tra:

   

=====

   java.heap.size.initial=256m

   java.heap.size.max=512M

=====


2). Stop Hawkagent and Administrator.


3). Remove caches or files from the <temp> folder and <TRA>/domain/<domain>/logs/ to make a clean environment for the domain.


4). Restart Hawkagent and Administrator.