BusinessConnect engines stop working under heavy load when processing synchronous inbound transactions.

BusinessConnect engines stop working under heavy load when processing synchronous inbound transactions.

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Article ID: KB0093744

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Description:
The BusinessConnect Interior Server engines stop working under a heavy load when processing synchronous inbound transactions. These synchronous transactions can be EDI X12, such as 270-271 request response. 
Symptoms:
When looking at the executing processes with the Hawk GetProcesses() method, a large number of processes are stuck at the task. (send-syncreply-get-confirmation).
Cause:
The client initiating the request to the Gateway Server disconnects because of an excessive wait time, which causes the Gateway Server to stop waiting for a response from the Interior Server. The Interior Server sends the response after this with a default timeout of one hour. Since the Gateway Server never responds, the engine will eventually hang because of an excessive number of jobs waiting to complete.

Issue/Introduction

BusinessConnect engines stop working under heavy load when processing synchronous inbound transactions.

Resolution

To resolve this issue, open the deployed Interior Server .tra files, and add the following parameter:


tibco.clientVar.gatewayProperties/transports/Intercomponent/dmzmsh/waitDuration=180000


This parameter limits the wait time for the Gateway Server response to the Interior Server to three minutes. Without this parameter, the default timeout is one hour. This will prevent a backlog of pending jobs in the Interior Server.

Additional Information

BusinessConnect Interior Server Administration Guide.