Work Item Scheduling Problem May Cause Halted Process Instances and Duplicate Work Items.

Work Item Scheduling Problem May Cause Halted Process Instances and Duplicate Work Items.

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Article ID: KB0084573

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Updated On:

Products Versions
TIBCO BPM Enterprise (formerly TIBCO ActiveMatrix BPM) -
Not Applicable -

Description

Description:
A process instance halts when scheduling a work item. On retry, the process instance may create a duplicate work item and halts again.

Symptoms
---------------

An error occurs when a process instance tries to schedule a work item, causing the process instance to halt.

When you retry the process instance (after investigating the cause of the error), the process instance should create the work item and
then continue. Instead, the work item is created, but a duplicate work item is also created and the process instance halts again with
the same error.

Further attempts to retry the halted process instance have the same result, until after a number of retries the process instance successfully
returns to "RUNNING" status. However, you may now have a number of duplicate work items.

Cause
---------

When the initial attempt to schedule the work item fails, Work Manager notifies Process Manager of the error. Process Manager handles
the error, but then incorrectly caches it. When you retry the process instance, Process Manager handles the cached error again, which
results in the process instance halting again and the creation of a duplicate work item. After a small number of retries (typically 4 or 5),
Process Manager discards the cached error, so that the next attempt to retry the process instance succeeds.  

NOTE: The caching problem does not occur in ActiveMatrix BPM 4.0.

Solution
-----------

IMPORTANT: Do not attempt to resolve this problem without the assistance of TIBCO Support.

Contact TIBCO Support, who will help you to resolve this problem using the following high-level procedure:

1. Retry each halted process instance. If it halts with the same error but creates a work item, take a note of the work item ID
(so that you can delete that work item later). Keep doing this until the process instance returns to "RUNNING" status.

2. Delete all the duplicate work items that have been created for each affected process instance. To do this:

i) Shut down the ActiveMatrix BPM system.
ii) Backup the ActiveMatrix BPM database.
iii) For each affected process instance, run the deleteWorkItemSP.sql stored procedure against each work item ID that you have identified
as a duplicate.
iv) Restart the ActiveMatrix BPM system.

3. To prevent the problem from happening again, investigate and fix the underlying cause of the original work item scheduling error.

Issue/Introduction

Work Item Scheduling Problem May Cause Halted Process Instances and Duplicate Work Items.

Attachments

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