Installed software does not show up the in theTIBCOAdministrator GUI after domain HawkAgent has been running for a longtime.

Installed software does not show up the in theTIBCOAdministrator GUI after domain HawkAgent has been running for a longtime.

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Article ID: KB0085106

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Updated On:

Products Versions
TIBCO Runtime Agent (TRA) -
Not Applicable -

Description

Description:
For large domains, installed software does not show up(sync up)  in the Installed Software list in TIBCO Administrator GUI although the domain HawkAgent has been running for long time (hours or days).
Symptoms:

Domain is upgraded to a higher TIBCO Runtime Agent (TRA) version, and a higher version of the BW/Adapter is installed, but the new software takes a long time to show up in the Admin GUI or never gets synchronized to the domain. 


If -tsm_traceLevel is set to -1 in hawkagent.cfg, the new software can be seen in tsm.log. There is no error or exception reported, but the TsmSyncInventory never ends as "Leaving thread TsmSyncInventory", like the following, does not appear in the tsm.log.

 

<--------- tsm.log --------
2016 Feb 05 11:41:47:591 GMT -5 tsm Debug [] [TRA-000000] Leaving thread TsmSyncInventory
---------->

Cause:

The TRA_HOME or TIBCO_HOME changed when the domain was upgraded. For example, the TRA_HOME might be changed from "C:/tibco/tra/5.7" to "C://tibco//tra/5.9" (double slashes), or "C:/tibco/tra/5.7" to "c:/tibco/tra/5.9" (lower-case 'c"). 

This can be seen by comparing the product location in tsm.log and the "Component Path" in the Admin GUI.

<---- tsm.log ----

2016 Feb 05 11:31:56:814 GMT -5 tsm Debug [] [TRA-000000] Thread TsmSyncInventory <?xml version = "1.0" encoding = "UTF-8"?>

<TIBCOProducts>

<product displayname="TIBCO ActiveMatrix Adapter for Files" version="6.1" maintenanceversion="0" updateversion="16" type="adfiles" location="C://tibco//adapter/adfiles/6.1">

<feature name="adapterapp">

<component componentdisplayname="TIBCO Files Agent" componentname="adfiles" deployactionspluginclassname="com.tibco.tra.tsm.plugin.TSMAdapterDeployActions" deploypluginclassname="com.tibco.tra.tsm.plugin.TSMGenericAdapterDeploy" isdeployable="true" isjava="false" name="adapterapp" paletteresource="adfilespalette" processname="adfilesagent" producttype="adfiles" relativeprocesslocation="bin" undeployactionspluginclassname="com.tibco.tra.tsm.plugin.TSMComponentUndeployActions" undeploypluginclassname="com.tibco.tra.tsm.plugin.TSMComponentUndeploy"/>

</feature>

</product>

</TIBCOProducts>

--->

The Hawk Agent will detect this change and thinks the original installed product is removed on the machine, even though the operating system treats double slashes in file path the same as single slashes and/or is not case-sensitive. In this case, the Hawk Agent will get all application configurations in the domain to check if the removed software is being used or not before removing or disabling it. This procedure could take a long time. This issue happens in large domains, especially when a product (BW or Adapter) is heavily used. For exmaple, hundreds or thousands of Adapter for Files applications are deployed in the domainIt can also happen when the domain uses a database for the domain data and the connection to the database server is slow. 



Issue/Introduction

Installed software does not show up the in theTIBCOAdministrator GUI after domain HawkAgent has been running for a longtime.

Resolution

Modify the value of tibco.env.TRA_HOME in the hawkagent_domainname.tra file so that the TIBCO_HOME matches the one before the domain is upgraded. For example, 
change "C://tibco//tra/5.7" to "C:/tibco/tra/5.7". Then restart the Hawk Agent. 

NOTE:If above  resolution is not helpful please see KB:38416 for other scenarios.