Service calls fail with "The XSD Cache is not available to the SOAP Binding".

Service calls fail with "The XSD Cache is not available to the SOAP Binding".

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Article ID: KB0093986

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Updated On:

Products Versions
TIBCO ActiveMatrix BusinessWorks -
Not Applicable -

Description

Description:
Service calls fail with "The XSD Cache is not available to the SOAP Binding".
Symptoms:
The following error is seen in the console log while running in Studio.

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[bwEngThread:In-Memory Process Worker-1] com.tibco.bw.binding.soap - TIBCO-BW-BINDING-SOAP-500070: Failed to process Reply message for Operation [{http://www.tibco.com/2df9f14a96394d1fa0cfb57fc5210952/iheservices}DocumentRepository_RetrieveDocumentSet], SoapServiceBinding [SOAPServiceBinding], Application [Caresource.IHE.XDSb.application:1.0] due to exception [java.lang.RuntimeException].  Sending Undeclared Fault message to the consumer of this service.  Root Exception message: [The XSD Cache is not available to the SOAP Binding] 

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Cause:
Namespace conflict issues at runtime if multiple documents share the same targetnamespace in single application module.

Issue/Introduction

Service calls fail with "The XSD Cache is not available to the SOAP Binding".

Resolution

Check your Service Descriptors project  folder if you have multiple  WSDL's with  same targetnamespace. There will be namespace conflict issues at runtime if multiple documents share the same namespace. If you cannot change it, merge the WSDL's with common namespace in to one single WSDL or use different application modules to service each of these WSDL's.