The BusinessConnect interior server fails to connect to trading partners via HTTPS when sending an outbound transaction.

book

Article ID: KB0094077

calendar_today

Updated On:

Products Versions
TIBCO BusinessConnect EDI Protocol Powered by Instream -
Not Applicable -

Description

Resolution:

When sending an outbound message to a trading partner via HTTPS, the BusinessConnect interior server fails to connect to a trading partner and returns the following error:

"Failed to send notification to trading partner. via https://<ip address>/AS2Receive/BTSHttpReceive.dll. StatusCode from Transport is: 699. StatusMsg from Transport is: Error connecting to host <ip address> at port 443. Broken pipe."

To resolve this issue, make sure that all certificates sent by a trading partner are added/uploaded under the trading partner's "Credential" tab. For that, go to Admin GUI > BusinessConnect > Participants > select Participant > go to the "Credential" tab and check that all certificates sent by the trading partner are present under this tab.

Issue/Introduction

The BusinessConnect interior server fails to connect to trading partners via HTTPS when sending an outbound transaction.

Additional Information

BusinessConnect Trading Partner Administration Guide