Unable to determine schema version. Make sure the DB user has the correct privileges.

Unable to determine schema version. Make sure the DB user has the correct privileges.

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Article ID: KB0093895

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Updated On:

Products Versions
TIBCO ActiveMatrix BusinessWorks -
Not Applicable -

Description

Description:
When the node is in group mode, the above message is reported during node startup. It happens when an application is deployed in FT or multiple node setup.
Symptoms:
Application is in impaired status. Checking the log show the following exception

2016-06-08 22:37:42.426 ERROR [CM Configuration Updater (Update: pid=bw.resource.jdbc.227cde25-7e91-407b-b10a-c47600d7b91a)] com.tibco.bw.frwk.engine.BWEngine - TIBCO-BW-FRWK-500001: BusinessWork Engine [Main] failed to deploy and start, <CausedBy> TIBCO-BW-CORE-500010: Failed to initialize BW Engine due to exception [com.tibco.pvm.system.util.exceptions.PmSystemException].
   <CausedBy> com.tibco.pvm.system.util.exceptions.PmSystemException: PVM-SYS-100131: Unable to determine schema version, make sure db user has correct privileges




Cause:
The Engine is unable to get the data from PE_DB_SCHEMA which exists in the group database. Run the following SQL from the console where the "create.sql" script is executed.

select VERSION, VERSION_TIMESTAMP from PE_DB_SCHEMA

Data : VERSION VERSION_TIMESTAMP
          2.2.0         16-JUN-16 11.48.14.826849 PM

If the console is able to return the above data, run the same from SQLPlus.If SQLPlus does not return the same, the issue is caused by Oracle default transaction behavior. All the database operations which were performed by create.sql is not committed into the database and the data is unavailable to other user sessions. 

Issue/Introduction

Unable to determine schema version. Make sure the DB user has the correct privileges.

Resolution

From the console where "create.sql" is executed, run the following command to commit all the changes

commit;