Siebel adapter is unable to receive request after a few hours.

Siebel adapter is unable to receive request after a few hours.

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Article ID: KB0092829

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Updated On:

Products Versions
TIBCO ActiveMatrix BusinessWorks Plug-in for Siebel -
Not Applicable -

Description

Description:
Upgraded from Siebel adapter 5.3.1 to 6.1.0. After every one hour or so, the Siebel adapter 6.1.0 is unable to receive any requests. Had to redeploy and restart the adapter to get the connections back to normal. Only restarting the adapter is not working.

Symptoms:

The following rpcc message is sent from Siebel server to the Siebel adapter. The replytimeout value is <TimeOut>0</TimeOut>.

 

<EventName>CreateCustomerAndAccounts_Event</EventName><VersionInfo>752</VersionInfo><TimeOut>0</TimeOut>


Cause:

For Siebel adapter 6.1.0, the ReplyTimeOut parameter is used for setting the waiting time for the reply from the event bus. If you set this value to 0, then the thread dispatched by adapter HTTP listener will wait for the reply from the event bus forever. If for some reason the event bus does not give the reply, then the dispatched thread is occupied forever as we only have a limited number of dispatched threads. When all the dispatch threads are occupied, the adapter stops working. The subsequent request to the HTTP listener will be blocked because the HTTP listener has no available dispatch threads.

 

Issue/Introduction

Siebel adapter is unable to receive request after a few hours.

Environment

Product: TIBCO ActiveMatrix Adapter for Siebel Version:6.1.0 OS: All Supported Operating Systems --------------------

Resolution

Configure Siebel server. Do not send replytimeout with value 0 from Siebel server to Siebel adapter.