Impact of Salesforce disabling TLS 1.0 on TIBCO BusinessWorks.

Impact of Salesforce disabling TLS 1.0 on TIBCO BusinessWorks.

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Article ID: KB0093964

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Updated On:

Products Versions
TIBCO ActiveMatrix BusinessWorks -
Not Applicable -

Description

Description:
Salesforce has disabled TLS 1.0 which causes BW clients (using HTTPS) trying to connect using TLS 1.0 to fail with the following error:

"TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or higher when connecting to Salesforce using HTTPS."




Symptoms:
BW clients trying to connect using TLS 1.0 fail with the following error:

"TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or higher when connecting to Salesforce using HTTPS."

Cause:
Salesforce has disabled TLS 1.0

Issue/Introduction

Impact of Salesforce disabling TLS 1.0 on TIBCO BusinessWorks.

Resolution

As TLS 1.0 is disabled, BW should use TLS 1.1 or higher for connecting to Salesforce. Follow the steps below to enable support  TLS 1.1 or higher. 

1)Apply the latest hotfix for BW and the compatible TRA.  As of July'16 here are the latest BW/TRA hotfix versions:
BW 5.13 hotfix-04 and TRA 5.10 hotfix-02
BW 5.12 hotfix-11 and TRA 5.9.0 hotfix-08  or TRA 5.9.1 hotfix-04
BW 5.11 hotfix-22 and TRA 5.8.0 hotfix-12

Please check if there are subsequent hotfixes and always try to apply the latest hotfix.
    
2). TLS 1.2 is not supported with Entrust so the security provider must be set to  "j2se" or "ibm" (for IBM JRE's only). This can be done by adding the following property to the deployed BW application .tra:     java.property.TIBCO_SECURITY_VENDOR=j2se

3). Add "TRA_HOME%/hotfix/lib/TIBCrypt.jar;" to the beginning of tibco.env.CUSTOM_CP_EXT in designer.tra / deployed application .TRA .

Additional Information

https://help.salesforce.com/apex/HTViewSolution?id=000221207#Whendisable