Troubleshooting Statistica licensing issues

Troubleshooting Statistica licensing issues

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Article ID: KB0083470

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Updated On:

Products Versions
Spotfire Statistica 8.0 and above

Description

There can be several licensing issues with Statistica. This knowledge base article addresses the typical issues and offers steps to resolve them. 

Causes:

I.  Single-user desktop users licensing issues are caused by:

1.  Installing on more computers than are allowed in the licensing agreement

2.  Installing with incorrect user information

3.  Sporadic licensing messages while connecting through Ethernet, wireless, or through a docking station, etc. 

4.  Incorrectly applying a license file

II. Network installs (which include all CNET, BNET, and Enterprise installs) with licensing issues are caused by:

1. The Statistica licensing service installed on more than one server

2.  Server is virtualized (see Error, "The desired vendor daemon is down" in Statistica licensing)

3.  License file applied incorrectly

4.  Hardware change on server

5.  Multiple .lic files in the FLEXlm folder (typical location is C:\Program Files (x86)\StatSoft (Dell or Statistica)\FLEXlm)

 

Issue/Introduction

Troubleshooting steps for common Statistica licensing issues.

Environment

Windows operating systems only.

Resolution

I.   Steps to resolve single-user desktop licensing issues for:

1.  One or more Statistica registered install must be uninstalled.  See What is the process for installing Statistica on a different computer (single-user desktop version)?

2.  Register with correct user information (the same user information must be provided or registration for the license file will fail)

3.  Make sure all network adapters enabled  Note:  USB network adapters must be plugged in. 

4.  Correctly re-apply the license file.  See How to apply a new license file (single-user desktop version)

 

II. Steps to resolve network licensing issues for:

1. To install and register on a new or different server. See Moving Statistica to a new server

2.  License file must be changed to match specifications of the virtual server. Create a case here with the following:  the stat.lic license file, located at :\Program Files (x86)\StatSoft\FLEXlm\, with virtual server MAC address, and server name (NetBIOS name).  If unable to create a case through the TIBCO Support Portal, create a case here.  

3.   Re-apply the license file correctly. See How to apply or install a license file (network installation)

4.   License file must be changed to match the server's new specifications. Send the stat.lic license file, located at :\Program Files (x86)\StatSoft\FLEXlm\, with new MAC address, and server name (NetBIOS name) to fulfillment (fulfillment@tibco.com).  

5.  Only a single license file should be located in the FLEXlm folder so delete all additional .lic files

Note: For other issues associated with network licensing, see Error, "The desired vendor daemon is down" in Statistica licensing

To contact Statistica Support, submit a case here.

 

 
 
 

Additional Information

Legacy Article ID: 126737