"Unable to see BC-Plugins" or "Seeing same version of bc" in installed software after uninstalling or upgrading BC.

"Unable to see BC-Plugins" or "Seeing same version of bc" in installed software after uninstalling or upgrading BC.

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Article ID: KB0083455

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Updated On:

Products Versions
TIBCO BusinessConnect -

Description

In new or upgraded environments, a user may not see the BusinessConnect Plugin appearing in the Administrator. Here are some possible causes and resolutions.

Possible Cause:

1). Missing RV / EMS path in the tibcoadmin_<domain_name>.tra file
2). Incorrect record in Admin tables.
3). Problem with bcwebadmin.war

Go to the resolution 1,2 or 3 according to the above possible case.

Issue/Introduction

In new or upgraded environment, a user may not see the BusinessConnect Plugin appearing in the Administrator. Here are some possible causes and resolution for this situation.

Environment

All

Resolution

Workaround/ Resolution Summary:-

1). Go to the following path 'TIBCO_HOME\tra\5.10\bin' and run the following command.
                  traUpgradeManager -path <TIBCO_HOME>\  -ems  <TIBCO_HOME>\ems\version
                  traUpgradeManager -path <TIBCO_HOME>\  -rv  <TIBCO_HOME>\tibrv\version

2). If your admin domain is configured using a database, then do the following.

     i). Clean BC related records from AdProduct and AdAdministratorPluginFile Tables from Administrator database.
     ii). Stop Admin and Hawk agents on that machines where BC is installed.
     iii). Delete BC related files from <Tibco-Home>/Administrator/domain/<Domain_Name>/server/webapps
     iv). Start Hawk Agent and Admin and verify the BC is listed in the installed software list of admin.
     v). If you don't see BC, you can try to add manually by importing the bcwebadmin.war (<BC_HOME>/admin_plugins) to administrator plugins.

    After doing the above steps you should be able to see BC-plugins in your Admin UI.

Additional Information (For DB based domain):-
    Adproduct:- It keeps/saves all product details in database which is installed in administrator.
    AdAdministratorPluginFile:- It keeps/saves all product plugins details in database which is installed in administrator.

3). if the issue persists further, refer to the steps below steps.

    i). Open the bcwebadmin.war file from below location.'<Tibco_Home>\administrator\5.x\administrator-plugins'
    ii). Change the .war file into .zip file and extract it.
    iii).  Inside the extracted folder we can see 'META-INF' folder.
    iv). After opening 'META-INF' folder we can see manifest.mf file.
    v). Open the file in notepad and just change the implementation version to one digit.
                       Example:- If Implementation-Version=6.3.0.16 then we will change into 6.3.0.17.
    vi). Save it , change into the .war file and restart the Administrator and Hawk.

If you need assistance with any of these resolution steps, open a Case with TIBCO Support.