Unable to start Spotfire Server Service with error "com.spotfire.server.ServerInitializationException: Unable to connect to the server database"

Unable to start Spotfire Server Service with error "com.spotfire.server.ServerInitializationException: Unable to connect to the server database"

book

Article ID: KB0079862

calendar_today

Updated On:

Products Versions
Spotfire Server All Versions

Description

Description:
Unable to browse the Spotfire Administration Console. Error in the "server.log" file (<Spotfire_server_install_dir>\tomcat\logs);
------------------------------------------------------
com.spotfire.server.ServerInitializationException: Unable to connect to the server database
------------------------------------------------------

Symptoms:
Unable to browse the Spotfire Administration Console. Error in the "server.log" file (<Spotfire_server_install_dir>\tomcat\logs);

--------------------------------------------
Caused by: org.springframework.beans.BeanInstantiationException: Could not instantiate bean class [com.spotfire.server.util.sql.DataSourceManager]: Constructor threw exception; nested exception is com.spotfire.server.ServerInitializationException: Unable to connect to the server database
    at org.springframework.beans.BeanUtils.instantiateClass(BeanUtils.java:141)
    at org.springframework.beans.factory.support.SimpleInstantiationStrategy.instantiate(SimpleInstantiationStrategy.java:108)
    at org.springframework.beans.factory.support.ConstructorResolver.autowireConstructor(ConstructorResolver.java:280)
    ... 73 more
Caused by: com.spotfire.server.ServerInitializationException: Unable to connect to the server database
    at com.spotfire.server.util.sql.DataSourceManager.awaitConnection(DataSourceManager.java:260)
-------------------------------------------- 

Cause:
This error indicates that there is an issue with connectivity to the Spotfire Database.

Issue/Introduction

Unable to start Spotfire Server Service with error "com.spotfire.server.ServerInitializationException: Unable to connect to the server database"

Resolution

Check the following:

-  If your Spotfire Database is up and running.
-  Check connectivity from the Spotfire server machine to the Spotfire Database Server using suitable Database client tools (e.g., DBVisualizer ).
-  Consult with your DBA if there is something wrong with the Spotfire Database.