"Unable to submit the CSR to the server Node" in the Node Manager log

"Unable to submit the CSR to the server Node" in the Node Manager log

book

Article ID: KB0081920

calendar_today

Updated On:

Products Versions
Spotfire Server All supported versions

Description

During a fresh installation, when we start up the Node Manager service, the Node Manager is not visible under "Untrusted Nodes". The Node Manager log file (nm.log) shows the following warning message:

=======================================
WARN <Datetime>
[] nodemanager.trust.CertificateMonitor: Unable to submit the CSR to the server Node [serverId=<Spotfire Server GUID>, serverName=<Server Name>, port=9443, online=true, siteID=<Site GUID>]: I/O error on POST request for "http://<Node Manager Hostname>:9080/spotfire/nodemanager/trust/initialize" :Connect to <Spotfire Server Hostname>:443 [<Spotfire Server Hostname>/<IP Address>] failed: Connection refused: connect; nested exception is org.apache.http.conn.HttpHostConnectException: Connect to <Spotfire Server Hostname>:443 [<Spotfire Server Hostname>/<IP Address>] failed: Connection refused: connect

======================================

Environment

Windows Server Operating Systems

Resolution

Cause:
The registration of a Node Manager on a Spotfire Server is always done on a clear text port (HTTP) whereas in the above scenario, there could be some automatic routing of the Spotfire Server URL from HTTP (9080) to HTTPS (443) that results in the Node Manager not being able to submit the certificate.

Resolution:
Make sure that there is no automatic routing of Spotfire Server URL from HTTP to HTTPS. 

Issue/Introduction

The Node Manager does not appear under the "Untrusted Nodes".