While registering adapter agent with tea server, it fails with error: "java.net.SocketException: Software caused connection abort: socket write error"

While registering adapter agent with tea server, it fails with error: "java.net.SocketException: Software caused connection abort: socket write error"

book

Article ID: KB0078307

calendar_today

Updated On:

Products Versions
TIBCO ActiveMatrix Adapter Framework All supported versions

Description

When tried to register the adapter agent with tea server, it throws below error: 
=====
pool-1-thread-1] WARN  c.t.a.m.p.r.AdapterRDBMSDataManager -
SQLState :  08S01
ErrorCode: 0
Message: The last packet successfully received from the server was 169,960,854 milliseconds ago.  The last packet sent successfully to the server was 169,960,885 milliseconds ago. is longer than the server configured value of 'wait_timeout'. You should consider either expiring and/or testing connection validity before use in your application, increasing the server configured values for client timeouts, or using the Connector/J connection property 'autoReconnect=true' to avoid this problem.
 Cause  : java.net.SocketException: Software caused connection abort: socket write error
[HttpClient-295] WARN  o.eclipse.jetty.client.HttpExchange - EXPIRED ContentExchangeWrapper@5f34c738=PUT//host:8777/teaa/task#WAITING(59990ms)->EXPIRED(0ms)sent=59990ms
[pool-1-thread-1] ERROR com.tibco.tea.agent - Auto registration failed with timeout error: STATUS_EXPIRED. 
=====

Cause:
This error caused due to the MySQL database server has terminated the connection with the adapter agent when configured in DBEMS mode. In most cases, this can be caused either by the timeout issue (e.g. the response takes too much time).
 

Issue/Introduction

While registering adapter agent with tea server, it fails with error: "java.net.SocketException: Software caused connection abort: socket write error"

Environment

Product: TIBCO ActiveMatrix Adapter Framework Version: All supported versions OS: All Supported Operating Systems

Resolution

To resolve this issue increase the wait_timeout with bigger value in config file at database side.

OR 

Update the JDBC url present in adapteragent.ini file with "autoReconnect=true" jdbc property
e.g
admin.technology.dbems.db.connectionURL=jdbc:mysql://<host>:<port>/adapteragentdb?useSSL=false&autoReconnect=true

When autoReconnect=true is set then database driver will try to re-establish the connection with the database.