How to permanently fix version manager enablement messages using Citrix and App-V?

How to permanently fix version manager enablement messages using Citrix and App-V?

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Article ID: KB0077932

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Updated On:

Products Versions
Spotfire Statistica 13.3 and higher

Description

If Citrix and App-V is used to published Statistica to users, users may see the following error when launching Statistica after upgrading from 13.1 to 13.5:


Statistica could not be enabled.

More than one enablement error

This can be resolved by running Statistica as admin as discussed in this knowledge article:   https://support.tibco.com/s/article/Statistica-Version-Management-Version-Manager
However, it was discovered users would have to launch Statistica as admin every time, but what is needed is a solution where a standard users would be able to launch Statistica without encountering the errors above. 


Cause

The error messages will appear if this fails:   "Register desktop STATISTICA if it starts from a different path than where it is registered.  "   If Statistica run with elevated/as admin permission, the registration will be updated.   More specifically, it goes through the files in RegisteredFiles.txt and re-registers them; it checks whether the app folder is the same as the one in this registry entry: 

HKEY_CLASSES_ROOT\CLSID\{C9E28000-3D45-11D4-9FF4-00C04FA0D540}\LocalServer32

Registry entry for start location of Statistica application

If Statistica is launched as a standard user and the location of the statist.exe file does not match the location, the enablement errors will appear.  Clicking "OK" and "Yes" will allow Statistica to still launch and run as usual, until it is closed and re-launched, when the messages will appear again. 
 

Issue/Introduction

This article discusses how to permanently fix version manger enablement messages that keep popping up with Citrix and App-V deployments.

Environment

Windows operating systems only.

Resolution

DISCLAIMER : TIBCO Software does not provide support for problems that arise from improper modification of the registry. The Windows registry contains information critical to your computer and applications. Make sure you back up the registry before modifying it. For more information on the Windows Registry Editor and how to back up and restore it, refer to Microsoft Article ID 256986.

With some implementations of Citrix and App-V virtual environments, the registry is "dynamic" and cannot be updated directly.  In this case, the registry must be updated via a script.  To do so,  export the registry entry, as below:
Export CLSID reg entry

Then with a script, perhaps a Powershell script or batch file, add the following command to update the registry before launching Statistica:

%SystemRoot%\regedit.exe /s "\\location_of_exported_reg_entry\CLSID_Statistica.reg"
"C:\Program Files\Statistica 13\statist.exe"