All table-based visualizations and Text Area visualizations are blank

All table-based visualizations and Text Area visualizations are blank

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Article ID: KB0080226

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Updated On:

Products Versions
Spotfire Analyst All Versions

Description

All table-based visualizations and Text Area visualizations are blank. This includes Table, Cross Table, Graphical Table, Summary Table, and Details-on-Demand.  No column headers are seen either.

No column headers are seen either. Other non-table-based visualizations display correctly as expected. This will be specific to a particular computer and or user and the same analysis may display correctly when viewed from another computer.

This issue can also result in the Spotfire desktop client (TIBCO Spotfire Professional) becoming unresponsive and hanging.

Cause:
When using tabular visualizations and Text Area visualizations, the Spotfire desktop client needs to start local http listeners. So when a restricted domain user experiences the above described behavior, it is likely that there is a setting or policy within the environment that prevents the user to start such listeners. The ports required for this are 8000 and higher i.e. 8000, 8001, 8002, etc, depending on how many simultaneous instances of Spotfire are being used and what ports are available. For example, http://localhost:8000.

Issue/Introduction

All table-based visualizations and Text Area visualizations are blank

Resolution

To resolve the issue, please check the following possible resolutions:
  1. Ensure the firewall is not blocking localhost:8000, 8001, 8002, etc.
    • Disable any locally running firewall and reopen TIBCO Spotfire
  2. Ensure localhost is mapped to 127.0.0.1 in the hosts file:
    • Check that localhost is properly resolved to 127.0.0.1. Open a command prompt and run "nslookup localhost".
    • If needed, update hosts file located here: C:\Windows\System32\drivers\etc\hosts
  3. Check if "Content Advisor" is blocking access to localhost:8000, 8001, 8002, etc.
    • Disabled Content Advisor (IE > Tools > Internet Options > Content > Disable Content Advisor
  4. Ensure another process is not listening/blocking localhost:8000, 8001, 8002, etc.
  5. Ensure the individual users running Spotfire have rights to the required ports 8000, 8001, 8002, etc.
    • If multiple users are facing the issue, we recommend contacting your IT department and explaining the problem to them. The issue is that there is a security policy in place, somewhere, that does not allow the groups having this issue to create internal http listeners on the required port numbers. This is most likely set as a group policy by your IT department, or as perhaps a security policy on a antivirus/application control environment.
    • Log in as a domain user with administrator rights on Windows (no restrictions) on the same machine and verify if Spotfire works as expected. If it does, you can resolve the problem for individual users by granting rights to single ports to the users experiencing the issue:

Windows 10, 8.1, 8, 7 & Vista
Referencing the following Microsoft article: http://technet.microsoft.com/en-us/library/cc754516(v=ws.10).aspx

You are able to verify if there is an active restriction, by granting rights for a single port to the particular user experiencing the issue. Run the following command as administrator from a command prompt:

  • netsh http add urlacl url=http://localhost:8000/ user=DOMAIN\USER listen=yes

where DOMAIN, and USER, should be changed to the corresponding values for the end user.

Keep in mind that the command is port specific. There is no guarantee that port 8000 is free (and maybe the user will start multiple instances of the Spotfire Desktop client); if it's not, Spotfire simply tries the next one (8001) and the next one, etc. So, it's a good idea to grant rights for a few additional ports, e.g.:

  • netsh http add urlacl url=http://localhost:8000/ user=DOMAIN\USER listen=yes
  • netsh http add urlacl url=http://localhost:8001/ user=DOMAIN\USER listen=yes
  • netsh http add urlacl url=http://localhost:8002/ user=DOMAIN\USER listen=yes
  • netsh http add urlacl url=http://localhost:8003/ user=DOMAIN\USER listen=yes

Windows XP
Referencing the following Microsoft article: http://msdn.microsoft.com/en-us/library/ms733768(v=vs.110).aspx

You are able to verify if there is an active restriction, by granting rights for a single port to the particular user experiencing the issue. Run the following command as administrator from a command prompt:

  • httpcfg set urlacl /u {http://URL:Port/ | https://URL:Port/} /aACL

where URL, Port and ACL should be changed to the corresponding values for the end user.

Keep in mind that the command is port specific. There is no guarantee that port 8000 is free (and maybe the user will start multiple instances of the Spotfire Desktop client); if it's not, Spotfire simply tries the next one (8001) and the next one, etc. So, it's a good idea to grant rights for a few additional ports, e.g.:

  • httpcfg.exe set urlacl /u http://localhost:8000/ /a "O:AOG:DAD:(A;;RPWPCCDCLCSWRCWDWOGA;;;S-1-0-0)"
  • httpcfg.exe set urlacl /u http://localhost:8001/ /a "O:AOG:DAD:(A;;RPWPCCDCLCSWRCWDWOGA;;;S-1-0-0)"
  • httpcfg.exe set urlacl /u http://localhost:8002/ /a "O:AOG:DAD:(A;;RPWPCCDCLCSWRCWDWOGA;;;S-1-0-0)"
  • httpcfg.exe set urlacl /u http://localhost:8003/ /a "O:AOG:DAD:(A;;RPWPCCDCLCSWRCWDWOGA;;;S-1-0-0)"

For information on the Access Control List (ACL) string required after the /a parameter in the form of a Security Descriptor Definition Language (SDDL) string, please see following reference article on the Security Descriptor Definition Language (SDDL) format:.

Additional Information

KB: 000029197 Spotfire Analyst displays an empty page KB 000021257 Newly installed TIBCO Spotfire 7.0.x (desktop client / Analyst / Professional) does not display visualizations.